0Home Page test forums PROGRAMMATION ARDUINO error arduino

This topic contains 1 reply, has 2 voices, and was last updated by  Baptiste 1 week, 2 days ago.

  • Author
    Posts
  • #14722

    Ali.Chalabi
    Participant

    Arduino:1.8.13 (Windows 10), Carte : “Arduino Uno”

    In file included from sketch\LinkedList.h:72:0,

    from sketch\MrlComm.cpp:10:

    sketch\LinkedList.cpp: In instantiation of ‘LinkedList<T>::~LinkedList() [with T = Device*]’:

    sketch\MrlComm.cpp:29:18: required from here

    sketch\LinkedList.cpp:21:13: warning: ISO C++ forbids comparison between pointer and integer [-fpermissive]

    while(root!=false) {

    ~~~~^~~~~~~

    sketch\LinkedList.cpp: In instantiation of ‘LinkedList<T>::~LinkedList() [with T = Pin*]’:

    sketch\MrlComm.cpp:29:18: required from here

    sketch\LinkedList.cpp:21:13: warning: ISO C++ forbids comparison between pointer and integer [-fpermissive]

    sketch\LinkedList.cpp: In instantiation of ‘ListNode<T>* LinkedList<T>::getNode(int) [with T = Device*]’:

    sketch\LinkedList.cpp:182:29: required from ‘T LinkedList<T>::get(int) [with T = Device*]’

    sketch\MrlComm.cpp:228:38: required from here

    LinkedList.cpp:53:10: error: cannot convert ‘bool’ to ‘ListNode<Device*>*’ in return

    return false;

    ^~~~~

    sketch\LinkedList.cpp: In instantiation of ‘ListNode<T>* LinkedList<T>::getNode(int) [with T = Pin*]’:

    sketch\LinkedList.cpp:170:29: required from ‘T LinkedList<T>::remove(int) [with T = Pin*]’

    sketch\MrlComm.cpp:297:24: required from here

    LinkedList.cpp:53:10: error: cannot convert ‘bool’ to ‘ListNode<Pin*>*’ in return

    exit status 1

    cannot convert ‘bool’ to ‘ListNode<Device*>*’ in return

    Ce rapport pourrait être plus détaillé avec
    l’option “Afficher les résultats détaillés de la compilation”
    activée dans Fichier -> Préférences.

    Comment resoudre ce problème?

  • #14879

    Baptiste
    Participant

    Salut

    Je pense que tu doit avoir trouvé depuis le temps mais ça vient de m’arriver aussi alors je relance le forum…
    J’ai trouvé sur : https://groups.google.com/g/inmoov/c/BxXm8lYALY0/m/OsJKgUvQGQAJ

    Il faut corrigé la ligne en defaut qui est en rouge et remplacer “False” par “NULL”

    a+

You must be logged in to reply to this topic.