Viewing 12 reply threads
  • Author
    Posts
    • #7109
      lecagnois
      Participant

      Dans la fenêtre DOS aprés une ou deux commandes
      j ai le message erreur qui viens de l’arduino

      [i01.left] ERROR class org.myrobtlab.arduino.Msg – Ack not receveived

      Cela plante InMOOV bien sur

      Quelqu un as t il une idée ?

      • This topic was modified 5 years, 9 months ago by lecagnois.
      • This topic was modified 5 years, 9 months ago by lecagnois.
    • #7112
      Christian
      Participant

      C’est signe que tu as perdu la communication avec ton arduino (il ne repond plus)

      A chaque message que MRL envoie a l’arduino, celui-ci confirme la reception du message avec un Ack

      C’est pas le Ack la cause du probleme, mais un signe que quelque chose ne va pas

    • #7113
      lecagnois
      Participant

      Merci de ta réponse christian , mais as tu une idée d ou cela vient ?
      Problème alimentation électrique ?

    • #7117
      Christian
      Participant

      si ton inMoov fonctionne puis cesse de fonctionner, c’est que ta connection usb est perdu, vérifie tes connection/qualité des tes cables USB

      si le inMoov ne fonctionne tout simplement pas, peut-etre qu’il ne peut pas se connecter a ton arduino

    • #7122
      lecagnois
      Participant

      Merci Christian
      le problème de déclenche après l’action des moteurs au bout d une ou deux commandes des servos
      avec un code très simple :

      leftHand.attach()
      #speed = vitesse main gauche pouce index majeux ring petit
      i01.setHandSpeed(“left”, 1.1, 1.1, 1.1, 1.1, 1.1, 1.1)
      i01.moveHand(“left”,170,170,170,170,150)
      talkBlocking(“ok j’ouvre ma main”)
      leftHand.detach()

      j ai également ce message
      [com7.portListener 1] ERROR c.myrobtlab.framework.Service -error serial
      ou encore
      [com7.portListener 1] ERROR c.myrobtlab.framework.Service -device does not exist

    • #7126
      lecagnois
      Participant

      j ai aussi ce plantage

      Arduino-> MRL error-bad magic number 7 – rx errors

      si tu a une idée ?

    • #7128
      Dominique
      Participant

      Tiens, c’est bizarre, il me semblait que la valeur de speed max valait 1, pour une vitesse plus lente, alors il faut mettre < 1 (0.9, 0.8, 0.7,….)

      Avant le detach, tu devrait mettre un petit délai, sinon ta main n’aura pas le temps de s’ouvrir.

      J’avoue que jamais je n’ai eu ce genre d’erreur…

      Quelle version de MrlComm et MyRobotLab utilise tu ?

    • #7129
      Christian
      Participant

      dominique a raison, les valeurs de speed doivent etre <= 1.0, mais ce n’est pas ce qui cause tes problemes de communication.

      Tes servo sont bien alimenté par une sources externe de courrant (batterie/power supply) et non pas directement sur l’arduino?

      d’apres les infos que tu me donne, l’arduino semble se reinitialiser lorsque tu bouge les servos.

      envoie un noWorky pour que je puisse avoir plus de détail

    • #7132
      lecagnois
      Participant

      Merci les gars de votre aide

      bon dans le fichier de config j ai mis a False autoattch et detach
      ;—————————– LEFT HAND CONFIGURATION —————————————-
      [MAIN]
      isLeftHandActivated=True
      autoAttach=False
      autoDetach=False

      J ai ajouté qq sleep et modifié la vitesse
      def compte123():
      leftHand.attach()
      i01.setHandSpeed(“left”, 0.9, 0.9, 0.9, 1, 1, 1)
      i01.moveHand(“left”,170,0,0,0,0)
      talkBlocking(“UN”)
      sleep(3)
      i01.moveHand(“left”,170,170,0,0,0)
      talkBlocking(“deux”)
      sleep(3)
      i01.moveHand(“left”,170,170,170,0,0)
      talkBlocking(“trois”)
      #i01.moveHand(“left”,170,170,170,170,0)
      #talkBlocking(“quatre”)
      #i01.moveHand(“left”,170,170,170,170,150)
      #talkBlocking(“cinq”)
      sleep(5)
      leftHand.detach()

      Résultat ben ca plante déjà un peu moins , mais sa plante parfois donc pas satisfaisant .

      Pour l’alimentation les servos sont alimentés par une alim stabilisé 6 volts
      et l’arduino par le port usb de l’ordi
      j utilise le servo board de Gael

      Euuuuuuuu c’est quoi un noWorky ???

      Version 1.0.1932
      Mrlcomm 54

      • This reply was modified 5 years, 9 months ago by lecagnois.
      • This reply was modified 5 years, 9 months ago by lecagnois.
      • This reply was modified 5 years, 9 months ago by lecagnois.
      • This reply was modified 5 years, 9 months ago by lecagnois.
      • This reply was modified 5 years, 9 months ago by lecagnois.
    • #7136
      anthony
      Moderator

      Hello lecagnois ! autoAttach et autoDetach sont à false par défaut, cette fonctionnalité qui sera très intéressante n’est pas encore validée dans mrl.
      Pour le noworky alors : tu reproduis le soucis et tu clique sur “help / about” en haut à droite. Tu va voir apparaître un bouton “no worky”

    • #7139
      lecagnois
      Participant

      Merci Anthony

      J ‘avais mis a True croyant qu il faillait les activer !
      Parce que au début les servo marchaient pas du tout .
      Si tu pouvais commenter le code un peu plus ça serais hyper sympa

      En tout cas Merci a tous

    • #7140
      anthony
      Moderator

      Si tu parle des fichiers de config, a terme ils seront générés automatiquement via une interface graphique. Cela va aider grandement les utilisateurs je pense.
      En attendant bonne idée ! on va polir cela en y ajoutant un peu plus de commentaires.
      maintenant que toutes les options de base sont présentes et fonctionnelles. Peut être que certaines comme “expérimentales” feront leur disparitions du premier plan du coup.
      Tu as pu envoyer ton “noworky” ? n’oublie pas le timbre 🙂

    • #7195
      lecagnois
      Participant

      Merci Anthony
      J ai modifié le code avec des tempos et j ai plus de message de communication
      Non j ‘ai pas réussi a faire un noworky j’avais plus de timbre (lol)

Viewing 12 reply threads
  • You must be logged in to reply to this topic.