0Home Page test forums Le forum Francophone Présentation fabrication du bras droit

Viewing 27 reply threads
  • Author
    Posts
    • #5672
      Anonymous
      Inactive

      Bonjour je m’appelle Ruben, 16 ans et je suis en première S.
      Je trouve votre projet super intéressant (comme la plupart des gens sur ce site :D) et je me lance donc dans la fabrication du bras droit d’inmoov dans le but de réaliser une prothèse dans le cadre de mon TPE (j’avais envi de me lancer dans la fabrication du robot et j’ai enfin trouver un prétexte pour le faire).
      J’était à la bibliothèque Saint Eloi le 26 octobre 2016 où j’ai pu rencontrer Gaël Langevin et fabriquer un prototype de la main finale ce qui à été une expérience très agréable et enrichissante que je conseille si l’occasion se présente.
      Rentrons dans le vif du sujet.
      J’ai quelque question concernant le bras.
      Le poignée ne permet qu’un seul mouvement? c’est ce qu’il me semble en regardant les explications de montage.
      Y a t il une réelle différence entre les HK15298 et les MG946? car ces derniers sont nettement moins chères.
      Merci pour votre attention.

    • #5683
      My’s Moov
      Moderator

      Bonjour, et bienvenue … pour le poignet oui un mouvement de rotation, pour le servo mais un 996R que tu peux trouver à bon prix moins de 5€.

      Bonne journée

    • #5686
      Anonymous
      Inactive

      Ok merci beaucoup pour ces réponses 🙂

    • #5699
      Anonymous
      Inactive

      Autre question
      Pour le tensionner, il faut des ressorts. Cependant, je ne sais toujours pas où les acheter après plusieurs recherches. Pourriez vous m’aidez svp?
      Merci

    • #5703
      My’s Moov
      Moderator

      Bonjour,

      Perso j’utilise des simples élastiques ça fonctionne à merveille et surtout beaucoup plus simple à mettre en place.
      Matt à remplacé les ressorts par des élastiques tu à ici la méthode pour le faire :

    • #5717
      Anonymous
      Inactive

      Ok merci beaucoup 🙂
      Effectivement c’est beaucoup mieux plus simple
      Les élastiques sont attachés à quoi ?(tige blanche)

    • #5721
      Gael Langevin
      Keymaster

      Hello Ruben,
      Ravi de te retrouver sur le forum et parmi nous apres cette session Numok.
      La technique des ressorts de Matt me parait tres bien et pratique. Selectionne des elastiques de dentiste, car les elastiques en silicone de “Loom” ne sont pas de bonne qualite et se craquele avec le temps.
      Les elastiques sont attache a la tige blanche.

      PS: sorry pour le clavier en qwerty sans accent.

    • #5757
      Anonymous
      Inactive

      Je suis ravi de même.
      Je vais essayer de trouver les élastiques. Ceux d’orthodontie fonctionne?
      Je suis actuellement à la moitié au niveau des impressions. Plus que l’autre et mon imprimante pourra souffler un petit peu :D.

    • #5941
      Anonymous
      Inactive

      petite question.
      Pour la graisse blanche pour le poignet, peut on utiliser du lubrifiant silicone ou obligatoirement de la graisse silicone?
      Merci

    • #5942
      Anonymous
      Inactive

      De la graisse blanche sous n’importe quelle forme ou seulement de silicone?

    • #5946
      Gael Langevin
      Keymaster

      Hello Ruben,
      Il existe de la graisse blanche chez Castorama qui est vendue, soit en tube, soit en spray.
      Je n’ai trouvé que celle en spray lors de mon shopping chez Casto, mais cela fonctionne très bien malgré tout.

      Attachments:
      You must be logged in to view attached files.
      • #5970
        lecagnois
        Participant

        Hello
        J ai testé la graisse blanche de chez CASTOCHE sur les conseils de Gael
        Résultat SUPER pas de décoloration sur le PLA (BLANC)
        Alors que sur mes autres pièces a la longue le PLA se décolore en rouge , car j avais utilisé de la graisse universel de couleur rouge.

        • This reply was modified 5 years, 11 months ago by lecagnois.
    • #5965
      Anonymous
      Inactive

      Très bien, je vais voir cela.
      Merci beaucoup

    • #5988
      Anonymous
      Inactive

      OK merci pour l’info, je vais aller en acheter.
      Je viens de recevoir les servos je vais enfin pouvoir continuer le montage 😀

    • #5991
      Anonymous
      Inactive

      Je rencontre un probleme.
      Après ouverture du colis, je m’aperçois que je n’ai pas les “adaptateurs” pour utiliser les servo-pulley et les servomoteurs sont trop grand pour rentrer dans les robring.
      Pouvez vous m’aider svp?

    • #7576
      Anonymous
      Inactive

      C’est bin j’ai fini le montage. Maintenant la programmation et de nouveau un problème.
      Je suis le tutoriel de Gael sur la chaîne string theory pour commander Le Bras avec la voix.
      Lorsque les moteurs sont débranchés, le programme fonctionne et répond. Cependant lorsque je les branches et que je lance le programme sur mrl, les doigts commencent à bouger puis j’entends le bruit de déconnection de périphérique Windows et mrl plante.
      Merci de votre aide 🙂

    • #7582
      Christian
      Participant

      Les servos ne doivent pas etre alimenté directement par l’arduino. L’arduino n’est pas capable de donner assez de courrant et cesse de fonctionner, faisant planté le tout

      Utilise des batteries tel que mentionné dans le tutoriel
      http://inmoov.fr/default-hardware-map/

    • #7589
      Anonymous
      Inactive

      Gael m’avait déjà donné ce conseil. J’allumente les moteur avec une alimentation de PC mais cela ne change pas.

    • #7597
      Christian
      Participant

      d’apres ta description du probleme, je suis certain a 100% que tu as un probleme d’alimentation. ton setup fonctionne jusqua ce que tes servos demande plus de courant que ton alimentation le permet. Ton arduino doit etre connecté sur la meme alimentation car il y voit un probleme et cesse de fonctionner pour se protéger.

    • #7615
      Anonymous
      Inactive

      Mais les doigts bougent un peu puis stop. C’est sûrement ca.
      Mais comment puis je alimenter la carte et les moteurs sur la meme alimentation alors que la carte doit être connecte sur le pc?
      Dois je brancher l’alimentation 5v de la carte sur mon alimentation(qui alimente les servo) et la prise USB à mon ordinateur en même temps ?

    • #7617
      Christian
      Participant

      battery connection

      ta carte Arduino est alimenté par le cable USB de ton ordinateur, c’est amplement suffisant pour elle

      Les servos ont un besoin différent, un ampérage beaucoup plus grand. La pin 5v de l’arduino n’est pas assez puissante pour fournir ce courrant. Tu as donc besoin d’un autre circuit électrice qui sera utilisé pour le mouvement de tes servos

      sur le schémas que j’ai mis, on utilise un breadboard pour répartir le courrant. La borne positive de la batterie est connecté sur le rail rouge ainsi que le fil v+ de ton servo (habituellement le fil rouge).

      la borne négative de la batterie est relier au rail noir ainsi que le fil – du servo (habituellement noir ou brun)

      Le signal provient de l’arduino, on connecte donc le fil S (jaune ou orange) du servo sur la pin que l’on veux sur l’arduino. Mais comme le courrant de la pin arduino provient d’un autre circuit électrique (le cable USB connecté a ton PC) il faut s’assurer que les deux circuit ait le meme référentiel. Pour cette raison, on relie les mise a terre (ground) de l’arduino a la borne négative de la batterie (sur le rail noir du breadboard).

    • #7618
      Anonymous
      Inactive

      Ah ok merci je viens de comprendre. Je pense que le problème viens du fait que l’alimentation de pc délivre une tension de 5v pour les servos. Et apres recherches je me suis aperçu qu’il fallait les alimenter avec une tensions entre 6V et 9V.
      Est ce là la source du problème ?

    • #7619
      Anonymous
      Inactive

      PS: j’utilise un Shield pour brancher les servos

    • #7620
      Christian
      Participant

      Souvent les servos ont besoin d’une alimentation differente de l’arduino. Mais ton probleme viens du fait que tu alimente tes servos a partir de l’arduino et ton arduino n’aime pas ca et s’eteint.

      Tu dois vraiment utiliser deux sources de courrant. un pour ton arduino (connection USB a ton PC) et une batterie pour tes servos. Sinon ca ne fonctionnera jamais, peu importe comment tu alimente ton arduino

    • #7624
      Anonymous
      Inactive

      Mais j’ai bien une alimentation externe pour les moteurs (mon alimentation de pc mais qui a une tension de 5V)

    • #7638
      Anonymous
      Inactive

      Voilà le montage avec une nouvelle alimentation de 9V mais le problème persiste.
      USB est branché à mon pc et le shield a l’alimentation 9V

    • #7639
      Anonymous
      Inactive

      Voilà la photo

    • #7746
      Anonymous
      Inactive

      C’est bon le problème venait du Shield qui ne permettait pas un GND commun à la carte et à l’alim contrairement à ce que je pensais. J’ai donc utilisé une bread board moins esthétique mais plus pratique. Maintenant que le contrôle vocal marche. J’ai une question, comment régler la position de départ et d’arriver des servo moteur pour l’ouverture et la fermeture de la main? j’ai essayer de modifier dans “def” mais rien ne se passe.
      Merci pour votre aide et surtout votre patience ;).

    • #8069
      Gael Langevin
      Keymaster

      Hello Ruben,
      As-tu installé la version complète pour InMoov qui permets de spécifier quelle partie du robot tu souhaites faire fonctionner?
      https://github.com/MyRobotLab/inmoov
      Avec cette version, tu peux configurer tes min et max pour chaque servo moteurs dans les dossiers de config.

Viewing 27 reply threads
  • You must be logged in to reply to this topic.