Viewing 63 reply threads
  • Author
    Posts
    • #4472
      anthony
      Moderator

      https://github.com/MyRobotLab/inmoov/wiki/HOWTO—SETUP-&-PREREQUISITES

      • This topic was modified 6 years, 6 months ago by anthony.
      • This topic was modified 6 years, 3 months ago by anthony.
      • This topic was modified 6 years ago by Sebastien.
      • This topic was modified 5 years, 9 months ago by anthony.
      • This topic was modified 5 years, 7 months ago by anthony.
    • #5437
      anthony
      Moderator

      *** mise à jour version MRL stable 1742 ***

    • #5444
      lecagnois
      Participant

      super anthony
      elle contient toutes les dernieres modif ?

    • #5448
      anthony
      Moderator

      Ca c’est juste pour avoir MRL en version de base
      Le paquet complet avec le script FR version du 18/10/16 : http://inmoov.fr/forums/topic/inmoov-ai/#post-4507

    • #5450
      lecagnois
      Participant

      merci tu est trop génial , pour le moment je suis en train d’imprimer à fond ,
      des que je peut je me remet à la programmation.

      • This reply was modified 6 years, 3 months ago by lecagnois.
    • #5457
      Pierrick
      Participant

      Salut Anthony,
      J’en suis resté à un de tes premiers packs et je n’ai pas les résultats que Rachel montre dans tes vidéos…. donc je m’attaque à ton dernier pack qui devrait me permettre d’avoir des réponses en français!
      J’ai récupérer des clefs comme tu l’as expliqué!
      Félicitations pour tout çà!

    • #6086
      anthony
      Moderator

      mise a jour du tuto mrl seul, pour compatibilité avec la dernière version de mrl 1803

    • #7333
      laurent
      Participant

      Bonjour Anthony, je suis carrément larguer avec l’installation de myrobotlab, serait il possible de discuter ensemble quelque minute par téléphone ?

    • #7335
      laurent
      Participant

      LES 5 premières étape pour moi ça va, c’est la sixième qui se gatte

      1/ Installer java 8 : http://java.com/fr/download/win10.jsp
      2/ Installez ou METTEZ A JOUR votre librairie arduino : https://www.arduino.cc/en/Main/Software
      3/ Installer Google Chrome ( utile pour la reconnaissance vocale )
      4/ Indiquer 115000 en vitesse de port com dans votre gestionnaire de périphérique
      5/ Téléchargez MRL http://mrl-bucket-01.s3.amazonaws.com/current/develop/myrobotlab.jar dans c:\mrl

      OK,
      6 ? 6/ Télécharger dans c:\mrl : https://github.com/MyRobotLab/inmoov/blob/master/tools/INSTALL_UPDATE_OR_RESET_MRL.bat ?

      je fait un copier des ligne et j’en fait quoi et comment ?? , je les transforme en ficier.BAT avec Notepad++ ? et je replace le fichier MRL.BAT existant par cela la ?? la je suis paumé

    • #7336
      anthony
      Moderator

      Bonjour Laurent ! pour l’étape 6 qui te bloque :
      Clique droit ici puis enregistrer sous ( c:\mrl ) https://github.com/MyRobotLab/inmoov/raw/master/tools/INSTALL_UPDATE_OR_RESET_MRL.bat

    • #7337
      laurent
      Participant

      bonjour, oui OK mais j’en fait quoi de ce fichier, je suis plutôt néophyte je le copy et le colle dans quoi ,? pour un novice si chaque étape n’est pas détaillé c’est galére , merci de m’indiquer les étape pas a pas svp

    • #7338
      anthony
      Moderator

      Comme indiqué il faud copier ce fichier dans c:\mrl , ensuite étape 7 : il faud l exectuter. Tu vois bientot le bout du tunel !
      Ce post est uniquement pour avoir mrl de base fonctionnel. Quand tu aurra reussi tu poura choisir ce que tu veux faire avec. Quel test souhaite tu effectuer dans un premier temps

    • #7339
      laurent
      Participant

      après avoir télécharger l’étape 3, et après ouverture du zip celui ci ne s’ouvre pas et affiche le message d’erreur que je joint ci-dessous

      Attachments:
      You must be logged in to view attached files.
    • #7341
      laurent
      Participant

      merci beaucoup Antony pour ton aide , et bien en faite imprimer y a pas de souci, assembler l’inmoove, y a pas de soucis, maintenant j’en suis a l’étape ou il va falloir faire bouger tous ces servos, que j’ai installer sur mon inmoove, je découvre donc le logiciel arduino, je decouvre donc MRL! et la semblerai que je suis incapable d’installer ces choses, voila ou j’en suis

    • #7342
      laurent
      Participant

      bon j’ai recommencer ! étape 1 a 5 OK !

      Etape 6 téléchargement https://github.com/MyRobotLab/inmoov/blob/master/tools/INSTALL_UPDATE_OR_RESET_MRL.bat ? ok

      installation sur c:\ mrl OK, mais il m’installe un fichier texte et non pas un exécutable et quand je le lance c’est le bloc note qui s’ouvre voir image jointe !, il ne m’installe donc rien

      Attachments:
      You must be logged in to view attached files.
    • #7347
      lecagnois
      Participant

      Salut Laurent

      tu trouvera dans MOD la première leçon pour installer tout ça
      J’espère que cela va t’aider

    • #7348
      anthony
      Moderator

      EDIT , merci lecagnois ! , on a posté en même temps

      Tiens, je t’ai fais un package avec tout ce qu’il faut dedans pour faire fonctionner mrl , de base, sans script
      On verra après pour aller plus loin.

      1 – Tu décompresse ce zip dans c:\mrl ( tu peux le vider avant )
      http://www.myai.cloud/mrl.zip

      2 – Il va falloir programmer tes arduino pour qu’ils fonctionnent avec mrl, pour cela il faut ouvrir le fichier MrlComm.ino qui se trouve dans le répertoire MrlComm. Et lancer le televersement bien sure.
      3 – Ensuite clique sur 1_INSTALL_UPDATE_OR_RESET_MRL, et patiente
      4 – Mrl est fonctionnel, tu peux l’ouvrir en lançant 2_SERVO_CALIBRATION.bat.

      5 – Il faudra choisir ton port com dans l’onglet arduino.serial
      6 – Ensuite le pin de l’arduino et enfin sélectionne “attach” pour démarrer le servo.

      • This reply was modified 5 years, 11 months ago by anthony.
    • #7350
      Bruno.Ash
      Participant

      Hi,
      Mes servos sont en cours de calibration via “2_servo_calibration.bat” installé au Carreau du Temple…
      Normalement (?!), je devrai avoir les premiers mouvements du bot cette semaine.
      Merci Anthony 😉

    • #7351
      laurent
      Participant

      ALORS LA, GROS MERCI VRAIMENT ! J’ESSAI CELA CE SOIR, ET JE VOUS TIEN AU COURANT DEMAIN! VRAIMENT MERCI

    • #7352
      lecagnois
      Participant

      Hello anthony
      (lol) mon MOD est toujours pas visibles 1 h20 après l’avoir mis en ligne , le site commence a être chargé

    • #7356
      laurent
      Participant

      hello Lecagnois ton MOD c’est ou çà ??

    • #7361
      lecagnois
      Participant

      essaye ici :

      https://inmoov.fr/forums/topic/lecon-n1-pour-debutant/#post-7359

      je sais pas pourquoi mais le post n’apparait pas dans la rubrique MODS

      Si le webmasteur peut faire qq choses ?

    • #7364
      Bruno.Ash
      Participant

      Salut Lecagnois,
      Erreur 404 sur le lien que tu donnes au dessus…
      Idem dans la rubrique “post récents” 🙁

    • #7365
      lecagnois
      Participant

      En attendant que le serveur fonctionne , je vous met en pièce jointe le document

      Attachments:
      You must be logged in to view attached files.
    • #7367
      laurent
      Participant

      OK merci beaucoup a tous, le temps d’assimilé tous cela et je revient vers vous pour la suite, merci pour vôtres
      disponibilités

    • #7368
      laurent
      Participant

      MERCI Anthony pour ton Package Nikel ! voila cela fonctionne MRL, j’arrive a sélectionner ma carte arduino, le com5 , jusqu’à l’étape 6 tous est OK !, voila du pas a pas pour un novice comme moi c’est parfait .)
      voila Antony quand tu aura du Temp je suis prêt pour la suite

    • #7372
      francis
      Participant

      Merci beaucoup

      C’est du beau boulot , chapeau bas

      paulo

    • #9482
      cyberneo
      Participant

      bonjour,
      je suis débutant, j’ai installé la derniere version de MRL mais je n’arrive pas a la configurer en francais, pour mouth c’est ok, pour ear aussi mais pour alice non,
      j’ai l’impression que dans les nouvelles versions il n’y a plus le fichier text inmoov pour modifier “en en fr”
      merci

    • #9483
      cyberneo
      Participant

      est-ce qu’il faut installer des versions précédentes avant?
      en fait mon premier but est de faire fonctionner le chatbot en francais avec commande vocale et synthèse vocale en francais en attendant de recevoir les arduino et servo pour les mains.
      merci

    • #9486
      anthony
      Moderator

      Coucou Samuel bienvenue parmi les robots !
      La procédure pour installer la version beta est toujours la même ( pour le moment )
      https://github.com/MyRobotLab/inmoov/wiki/HOWTO—SETUP-&-PREREQUISITES

      Comme tu n’as pas encore d’arduino, tu peux arrêter a l’étape 6 et interagir avec vinmoov.
      Pour tout mettre en français :
      Ouvre le fichier de config : _inmoov.config
      Remplace : MyLanguage=en par MyLanguage=fr
      Ensuite pour avoir une vraie voix en français :

      MyvoiceTTS=MarySpeech
      MyvoiceType=upmc-pierre-hsmm

      ou pour utiliser un autre synthétiseur, par exemple celui de windows

      MyvoiceTTS=MicrosoftLocalTTS
      MyvoiceType=0

    • #9487
      cyberneo
      Participant

      Merci beaucoup pour ta réponse,
      Malheureusement, je ne trouve pas le fichier _inmoov.config

      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
    • #9490
      lecagnois
      Participant

      Commence par créer un répertoire MRL tu copy les fichiers myrobtlab.jar et le fichier START-INMOOV.bat dedans
      Après

      il te faut extraire les paquets de myrobotlab.jar
      avec le fichier START_INMOOV.bat
      Anthony a fait une doc ici
      https://github.com/MyRobotLab/inmoov/wiki/HOWTO—SETUP-&-PREREQUISITES

      Une fois installer (attendre un très long moment)
      tu aura une répertoire mrl/inMoov/config/-inMoov.config

      Pour la voix MarySpeech cela fonctionne voix maculine en francais

      Pour la voix microsoft message erreur manque le répertoire tts et le fichier tts.exe

      Voila , j espère que cela va t ‘aider

    • #9491
      cyberneo
      Participant

      merci pour votre aide,
      sur le coup j’ai vraiment l’impression d’etre une bille…

      peut etre du au fait que je l’ai installé, effacé et réinstallé je n’arrive pas a charger les programmes dans runtime sur la version 1.0.1758
      https://goopics.net/a/aiiorn8g

      j’ai donc réinstallé la version 1.0.1723 ou j’arrive a installer tous les programmes dans runtime mais je ne vois toujours pas de fichier inmoov.config se créer.
      https://goopics.net/i/appkZ

      il doit y avoir quelque chose que je ne fais pas correctement.

      merci

      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
      • This reply was modified 5 years, 3 months ago by cyberneo.
    • #9499
      Dominique
      Participant

      ouille, la dernière version est la 2583… Normal que tu ne trouve pas la base InMoov.

      Tu doit télécharger le dernier build… Tu doit surement créer un compte chez MRL.

      Bonne continuation

    • #9525
      anthony
      Moderator

      En effet la version 1.0.1723 date un peu ! le lien pour la dernière build est ici, à l’étape 4 :

      https://github.com/MyRobotLab/inmoov/wiki/HOWTO—SETUP-&-PREREQUISITES

    • #9526
      cyberneo
      Participant

      Merci a tous pour votre aide,
      Apres tous vos conseils que je suivais du mieux que je pouvais, toujours rien donc je suis allé voir dans le fichier start inmoov.bat et la j’ai compris le problème, le traducteur de page google a modifié des “if” en “si”…
      Mon fichier.bat etait mauvais et ne pouvais pas lancer les lignes de commandes…
      Merci beaucoup !

      • This reply was modified 5 years, 3 months ago by cyberneo.
    • #9530
      lecagnois
      Participant

      @ hello a tous
      les beaux jours se terminent je me remet a mon robot .
      je m’étais arrête a la version 1954 de mrl ( avec plein de test et modifs que j avais fais et pas mal de script en python ) et la voix en français avec MicrosoftSpeech et Jampal de dominique

      je vois que pendant cet été vous avez travaillé comme des fous est mrl en est à la version 2585
      et la, il y a plein de nouveautés.

      Je voudrais tester la voix MicrosoftLocalTTS de anthony
      après avoir modifier le fichier config j’ai un message erreur

      could not set voice to{}
      dans la fenêtre système error c.m.service.MicrosoftLocalTTS – tts\tts.exe chemin introuvable

      Il manquerai un répertoire tts et le fichier tts.exe
      Faut il installer ce module séparément comme Jampal ?
      Si oui comment fait on

      Merci

    • #9533
      anthony
      Moderator

      coucou lecagnois fini les vacances 🙂
      je dirais même qu’on en est à la version 2590, qui corrige un bug pour les utilisateurs de windows 32bit, ceci concernant la synthèse vocale de Windows. Tu es bien en 32 bit ? tu as gagné une mise à jour 🙂 ( copier / coller du jar )
      Une astuce en bonus pour avoir une voix d’homme ( paul ) gratuite ( si tu utilise windows 10 … ) http://myrobotlab.org/service/MicrosoftLocalTTS?branch=develop . Il y a aussi le lien que Dom a posté , faut passer à la caisse https://best-of-vox.com/windows , les voix sont vraiment classe par contre.

      pour la remise à niveau , dans les grande lignes

      Nombreux bug corrigés dont tracking, détachement des servos etc , …

      Concernant mrl en général la documentation est en cours de rafraichissement, cette doc et les script test sont utiles pour comprendre comment fonctionnent les services en mode “brute” : http://myrobotlab.org/matrix.php et aussi tester chaque build avant publication pour ne rien casser.

    • #9535
      lecagnois
      Participant

      hello anthony
      Merci de ta réponse et pour les liens
      suis windows 10 64 bits malgrés modification registre tjts pareil
      ci joint capture écran

      il trouve pas le fichier tts.exe ?
      à la commande dos dos command : tts\tts -V
      j’ai la réponse n’est pas reconnu comme commande interne ou un programme éxecutable
      c’est sur vu que j’ai nul par ce fameux fichier ?

      nota trouvaille :
      Pour les développeurs de mrl(j ai trouvé ca pour faire parler cortana avec un fichier texte)
      http://www.mediaforma.com/windows-10-faire-lire-un-fichier-texte-par-cortana/
      un petit scrib vb tout simple .

      Attachments:
      You must be logged in to view attached files.
    • #9538
      laurent
      Participant

      bonjour ouaa2590 (je dirais même qu’on en est à la version 2590) , serait il possible d’avoir le lien de cette version, 2590 car avec ma lenovo 32 bit je galère beaucoup, merci

    • #9540
      anthony
      Moderator

      Le lien se trouve dans le tuto, étape 5 : https://github.com/MyRobotLab/inmoov/wiki/HOWTO—SETUP-&-PREREQUISITES

      @lecagnois
      ton java est peut être en 32 bit, sinon je vois que tu es encore en 2585, télécharge la dernière version
      Au pire le fichier est ici : https://github.com/MyRobotLab/repo/blob/develop/tts.microsoftspeech/1.1/tts-microsoftspeech.zip?raw=true

    • #9547
      lecagnois
      Participant

      @anthony

      Merci cela va mieux avec le fichier tts.exe .
      Je vois qu il est implémenté avec la version 2590
      je vais pouvoir encore bien m amuser pour cet hiver .

      Attachments:
      You must be logged in to view attached files.
    • #9560
      laurent
      Participant

      hello Anthony, alors version 2590 installer ! très amusant quand il ma chanter New York 😉 par contre un truc ne fonctionne pas , mes yeux en y, mes yeux en x pas de soucis , je met le mini, maxi et nickel, par contre en y le curseur ne fait pas bouger les yeux, de-plus, quand je lui dit regarde moi, il tourne les yeux (x) a droite et il est donc obligé de faire du contorsionniste avec ça tète pour me suivre, pourquoi en mode regarde moi il na pas les yeux en face mais a droite ?

    • #9579
      anthony
      Moderator

      Coucou les gars !
      Hihi oui on va passer encore un hiver à bricoler Inmoov !
      pour l’axe Y le servo n’est pas grillé ?
      Concernant l’axe X essaye d’inverser le servo ( setinverted=True )

    • #9582
      laurent
      Participant

      bonjour Anthony ok ct l’inversion, quand a l’axe y j’ai pas encore contrôler le servo

    • #9584
      Dominique
      Participant

      Je pense aussi faire un service spécifique pour ces yeux.

    • #9602
      Rohmer
      Participant

      Bonjour, tous le monde…..j’avais une question concernant l’utilisation de MRL connecté à 2 cartes arduino 2560 sans servos. Normalement si je lance Myrobotlab.1.0.2340 et ayant configuré tous les paramètres, je devrais avoir les petites leds qui clignotent en envoyant une commande vocale pour bouger les doigts par exemple ou d’autres organes d’InMoov, mais malheureusement je n’ai rien de tout celà, j’ai dû louper un truc, comment fait-on pour activer les commandes vocales de manière à faire démarrer les servos ?
      Y-a-t-il une âme charitable que je remercie d’avance.

    • #9605
      anthony
      Moderator

      Hello Rohmer !

      En effet le sapin de noël doit s’allummer

      Tu as bien activé :
      ScriptType=Full ( _InMoov.config )

      et par exemple
      isRightHandActivated=True ( skeleton_rightHand.config )

      Quand tu bouge les sliders des servo que se passe t il ?

      La dernière version beta est 1.0.2595

    • #9607
      Rohmer
      Participant

      Salut Anthony, je te remercie beaucoup pour ta réponse, en effet je n’avais pas changer les données dans le fichier config, mais l’anglais et moi ça fait 2 je ne comprend pas grand chose. Par contre mon robot ça fait 6 mois qu’il est terminé, mais jusqu’a présent j’ai utilisé la carte Maestro de Polulu pour l’activation des membres, celà était bien plus facile pour mes petits enfants pour donner vie à InMoov.Ca leurs à permis de programmer des séquences et des gestes dans la plus grande simplicité. Mais je dois avouer que quand j’ai vu ton travail et ce que ton InMoov arrive à faire, j’ai tout démonter pour pouvoir y inclure les 2 cartes arduino. Maintenant je suis revenu à la case départ.J’ai beau chercher je ne trouve pas la version de MRL 1.0.2595. J’ai encore beaucoup de chose qui ne sont pas clair, Myrobotlab n’est pas simple pour tout le moonde, mais étant à la retraite tous les jours de ma vie y seront consacrés.Encore merci.

    • #9608
      Rohmer
      Participant

      Mon MRL démarre bien pour l’instant et j’ai bien les servos qui bougent quand je manipule les sliders, par contre aucune commande vocale française” ouvre la main gauche ” ne fonctionne et active le signal arduino, il n’y a que le chatbot qui me parle.

    • #9615
      Rohmer
      Participant

      Au secours , Myrobotlab version 1.0.2340 fonctionne en US et commande bien mes servos, mais en fr rien à faire il n’y a que le chatbot qui me répond mais aucun servos ne démarrent. Je ne doit pas être loin du fonctionnement total mais j’ai dû louper un truc….un petit conseil please ???

    • #9619
      anthony
      Moderator
    • #9620
      lecagnois
      Participant

      @hello anthony
      En testant inmoovGestures.aiml je vois plein d anomalies ,
      des méthodes qui n’existe pas :
      (sans parler des accents manquant pour reconnaissance vocale en français)

      exemple :
      avec le mot MANUEL
      <oob><mrl><service>i01.ear</service><method>lockOutAllGrammarExcept</method></mrl></oob></template

      renvoi : did not find method

      pour arrête d’écouter :
      <mrl><service>i01.ear</service><method>stopListening</method></mrl></oob>
      renvoie :
      i01.ear error WebkitSpeech : TOO MANY EVENTS please close ZOMBIZ tabs

      Ma question existe – il une liste des méthodes implémenté dans
      dans i01.ear ?

      ou même i01 en entier..

      Pour les scripts python qui sont lancé c’est plus facile de les décortiquer pour les adapter ou modifier (lol).

      Merci d’avance de tes conseils

      • This reply was modified 5 years, 3 months ago by lecagnois.
      • This reply was modified 5 years, 3 months ago by lecagnois.
    • #9635
      jacque
      Participant

      hello docteur Anthony mon robot a le torticolis avec la version 2590 au démarrage de la tète elle tourne direct sur la droite et bouge plus a tu une idée tu problème? le chabot fonctionne mais pas le ear.addcommand comment l’activé merci a d’avance

    • #9637
      Rohmer
      Participant

      Bonjour,
      Effectivement je confirme que InMoov ver.2590 tourne la tête à fond sur la droite quand on démarre MRL et se remets droit quand le chatbot annonce démarrage de la tête….
      Par contre moi je n’arrive pas à résoudre le problème de l’omoplate gauche qui n’accepte pas l’inversion de sens, le bras rentre dans le corps et pas moyen de le faire changer de direction, j’ai beau permuté les fils sur le servo ni false ni true dans la config y change quoi que ce soit.

    • #9658
      Bruno.Ash
      Participant

      Salut,
      Tête à droite sur démarrage 2590 également… A droite donc sur sa gauche en deux ou trois impulsions !

    • #9659
      jacque
      Participant

      Salut à tous, pour la Tête personne a une idée moi elle reste bloqué à droite et le servomoteur fait du bruit ? Pour les commandes ear.addcommand ne fonctionne pas chez moi quand je lui demande ouvre les mains il ne se passe rien par contre chabot fonctionne, sur les anciennes versions MRL on pouvait activer soi chatbot ou ear.addcommand j’ai dû louper un truc, une aide serait la bien venue

    • #9661
      anthony
      Moderator

      coucou les gars !


      @lecagnois

      merci pour les test ! lockOutAllGrammarExcept + stopListening réparé ( bientôt mis à jour ).
      Pour les accents je veux bien un exemple ( attention aux faux positifs, ce sont des redirections )

      Pour la doc des méthodes disponibles voici la liste “javadoc” brute pour le service Inmoov :
      http://34.201.4.170/deploy/develop/javadoc/org/myrobotlab/service/InMoov.html
      Pour le service WebkitSpeechRecognition:
      http://34.201.4.170/deploy/develop/javadoc/org/myrobotlab/service/WebkitSpeechRecognition.html


      @jacque

      Essaye d’inverser le servo rothead ( dans le fichier de config )
      [SERVO_INVERTED]
      rothead=True

      @Rohmer et les autres pour l histoire de la tête
      Je vais jeter un œil ça fait ça aussi sur la dernière build ( 2602 ) ?

    • #9670
      anthony
      Moderator

      Au fait @Rohmer , ton problème d’omoplate vient certainement d’une inversion des fils du potentiomètre

    • #10527
      brice
      Participant

      Bonjour à tous.

      Je me lance dans mrl et tente déjà de mettre le langage en français.
      J’ai bien modifier le en en fr mais je ne voit pas ou mettre les lignes :
      MyvoiceTTS=MarySpeech
      MyvoiceType=upmc-pierre-hsmm

      Merci de votre aide.

      BRICE

    • #10530
      lecagnois
      Participant

      hello brice

      en version 2693 tout ce passe dans le répertoire
      InMoov/config

      il faut modifier le fichier service_5_Mouth.config

      exexple pour le francais

      
      [TTS]
      
      Speechengine=LocalSpeech
      
      ; you can use : 
      ;MarySpeech : open source TTS : http://myrobotlab.org/service/MarySpeech
      ;LocalSpeech : Local operating system TTS : http://myrobotlab.org/service/LocalSpeech
      ;Polly : [NEED API KEY AccessKey (apiKey1) and SecretKey (apiKey2)] http://myrobotlab.org/service/Polly
      ;VoiceRss : [NEED API KEY (apiKey1)] Free cloud service : http://myrobotlab.org/service/VoiceRss
      ;IndianTts : [NEED API KEY (apiKey1) and userid (apiKey2)] Hindi support : http://myrobotlab.org/service/IndianTts
      
      VoiceName=2
      ;VoiceName=cmu-bdl-hsmm
      ; MarySpeech voices - take HSMM ones - http://myrobotlab.org/content/marytts-multi-language-support
      ; LocalSpeech : use local windows voices/macOs ( 0,1,2 etc ) print mount.getVoices()
      ; amazon polly :  http://docs.aws.amazon.com/polly/latest/dg/voicelist.html
      
      [API_KEY]
      apiKey1=
      apiKey2=
      

      et le fichier _InMoov.config

      dans Language mettre fr

      exemple ici en français sans carte arduino:
      [MAIN]
      ScriptType=NoArduino
      ; RightSide: Also called FINGERSTARTER : connect one arduino ( called right ) to use FingerStarter + inmoov right side
      ; LeftSide: connect one arduino ( called left) to use head / inmoov left side
      ; setup your com ports inside service_6_Arduino.config
      ; NoArduino: vocal Only
      ; Full: Both side arduinos connected
      ; Virtual: virtual arduino and inmoov !
      debug=True

      Language=fr
      ; en,fr,es,de,nl,ru,hi

      • #10541
        brice
        Participant

        Merci beaucoup.

        Cela fonctionne très bien, mais peu t’on mettre une voie masculine ?

      • #10543
        lecagnois
        Participant

        @hello brice
        Anthony l’a expliqué en commentaire
        ; LocalSpeech : use local windows voices/macOs ( 0,1,2 etc ) print mount.getVoices()

        donc dans VoiceName= tu mets 0 1 ou 2 etc … cela dépend des voix installées sur ton windows

    • #11987
      LOMBARD Georges
      Participant

      Bonjour
      J ai démarré mon projet par lé finger starter qui fonctionne très bien avec l arduino mais j ai un soucis avec la commande vocale , le micro est bien activ il reconnaît ma voix mais je n ai pas de réponse dans l onglet i01 mounth j ai un message qui dit que maryspeech n a pas interface utilisateur
      Je travaille sous Mac et j ai la version myrobotlab 2693
      J ai réalisé déjà 3 post et 0reponse , je commence à être désespéré car je ne peux pas avancer sur mon projet
      Merci d avance pour votre aide.

    • #12316
      chrisdebacker
      Participant

      Bonjour a tous, voila plusieurs jours que j essaie de configurer et essayer myrobot lab, étant sur la phase finale de la construction de inmoov et bah je suis totalement perdu, et n arrive a rien , d un coté en suivant le tuto du finger starter je n ai pas de résultat et de l autre en essayant le version mrl de inmoov pareil je suis complètement perdu, je cherche cherche encore mais aucun résultat, et voila que maintenant la page web avec la reconnaissance vocale me marque erreur 404 et plus rien , est ce que quelqu un pourait m aider a mieux comprendre et configurer le logiciel je vous en serais reconnaissant

    • #12475
      Anonymous
      Inactive

      Greate.

      Podcast

Viewing 63 reply threads
  • You must be logged in to reply to this topic.