Forum Replies Created

Viewing 15 posts - 1 through 15 (of 396 total)
  • Author
    Posts
  • #12236

    anthony
    Moderator

    Coucou !

    dans ton fichier de config head.config, section [INVERTED]

    eyeY : il manque le paramètre, par exemple eyeY=True

  • #12114

    anthony
    Moderator

    génial !

  • #12113

    anthony
    Moderator

    Hello Baptiste, toujours coincé ? peux tu publier ton fichier myrobotlab.log ? Et si possible tes fichiers de config ? par exemple dans un zip

  • #11969

    anthony
    Moderator

    Tu as une erreur lors du lancement de la branche develop ? Tu as essayé le jar dans un répertorie vide ?
    Ah, concernant la compilation de manticore, on utilisait apache ant pour compiler.
    C’est peut être mieux que tu compile la branch master pour le moment.
    Il faud cloner aussi le repository “repo” qui contenait les dépendances : https://github.com/MyRobotLab/repo.git
    Tu va retrouver donc 2 repertoires myrobotlab et repo.
    il te faut :
    – GIT ( avec git dans le path windows ) : https://git-scm.com/download/win
    – ANT 1.8.2 : https://archive.apache.org/dist/ant/binaries/apache-ant-1.8.2-bin.zip

    git clone https://github.com/MyRobotLab/myrobotlab.git
    git clone https://github.com/MyRobotLab/repo.git

    cd myrobotlab

    ant jar

    tu trouvera le jar dans build/lib

    https://github.com/MyRobotLab/myrobotlab/issues/364

  • #11955

    anthony
    Moderator

    Salut !
    Ah ce message est lié au fait que les dernière versions de maven ( > 3.3 ) nécessitent java JDK, avec la variable java_home qui pointe dessus.

    Je viens de rafraichir un peu la doc ..

    compilation : http://myrobotlab.org/content/myrobotlab-local-maven-compilation
    première prise en main du projet dans eclipse : http://myrobotlab.org/quick_start
    Contributions : http://myrobotlab.org/content/myrobotlab-contributions-java-land

  • #11840

    anthony
    Moderator

    Hello Pascal le fichier à injecter se trouve dans ton répertoire MRL, double clique sur MrlComm.ino dans : resource\Arduino\MrlComm .

    Une fois ton arduino flashé, active la tête dans InMoov\config\skeleton_head.config ( isHeadActivated=True )

    Et change le fonctionnement de virtuel à materiel :

    InMoov\config\_InMoov.config ( ScriptType=LeftSide ) au lieu de ( ScriptType=Virtual )

  • #11839

    anthony
    Moderator

    Bonjour pierrot ! A l’avenir ( pour la version après Nixie ) on aurra la possibilité d’ajouter autant de servo que l’on souhaite facilement.

    Tu peux trouver le code qui gère les paupières ici, directement dans le code java:

    https://github.com/MyRobotLab/myrobotlab/blob/develop/src/main/java/org/myrobotlab/service/InMoovEyelids.java

    On y trouve 2 servo :eyelidleft + eyelidright.
    tu peux y ajouter eyelidleftTop par exemple.

    Pour le moment, cela implique de recompiler soit même le framework, apres la modif. Veux tu quelques explications la dessus ?

  • #11527

    anthony
    Moderator

    Salut Pascal, n’hésite pas si tu as des questions, en attendant que ce soit ton fils qui nous file un coup de main !

  • #11439

    anthony
    Moderator

    Hi valentin, set :

    VoiceName=0 ( or VoiceName=3 )

    instead of VoiceName=NICOLAI16

  • #11074

    anthony
    Moderator

    Coucou ! si tu cherche a remplacer ce que fait le pir,

    De mémoire tu as la commande “fais dodo” ou METS TOI EN VEILLE
    La commande pour réveiller est ici

    https://github.com/MyRobotLab/inmoov/blob/master/InMoov/config/service_4_Ear.config.default#L9-L10

    par exemple tu remplace wake up par bonjour. c’est le mot clé qui sera conditionné dans le service du micro

  • #11021

    anthony
    Moderator

    tiens essaye ceci

    • This reply was modified 1 year, 2 months ago by  anthony.
    Attachments:
    You must be logged in to view attached files.
  • #11018

    anthony
    Moderator

    Salut ! Ack not received signifie une perte de com avec l’arduino. Quelques pistes si ça fonctionnait avant :
    – utilisation d’un hub usb non alimenté
    – manque d’une mise à la masse quelquepart
    – Manque d’ampérage
    – une gestuelle qui fait bouger un fil ..

    Au pire essaye de déconnecter tous les éléments, et rebranche 1 par 1 voir lequel cause le soucis

  • #11016

    anthony
    Moderator

    ah le site a tronqué des chose : urllib2.urlopen(‘http://www.google.fr’).read()

    https://docs.python.org/2/howto/urllib2.html

    • This reply was modified 1 year, 2 months ago by  anthony.
  • #11011

    anthony
    Moderator

    Je te conseille de faire un copier/coller d une gestuelle existante par exemple

    davinci.py -> allume.py

    AIML :

    <category><pattern>ALLUME LE SALON</pattern>
    <template><oob><mrl><service>python</service><method>exec</method><param>allume()</param></mrl></oob></template>
    </category>

  • #11001

    anthony
    Moderator

    coucou ! voici une commande python :

    print urllib2.urlopen(“http://www.google.fr”).read()

Viewing 15 posts - 1 through 15 (of 396 total)